So zeigen Sie Fehlermeldungen an ()

Willkommen hier Sven und heute bringe ich dir diesen neuen Beitrag.

Während der Entwicklung eines Plugins möchten Sie möglicherweise Fehlermeldungen sehen, wenn etwas schief gelaufen ist, zum Beispiel die PHP-Version des Benutzers ist zu alt. Sie können die integrierte wp_die()-Funktion von WordPress verwenden, die eine attraktivere Fehlermeldung erzeugt, in der wir nützliche Links usw. bereitstellen können.

Die Funktion wp_die() ist so konzipiert, dass sie kurz vor ihrem Tod ausgibt, um leere oder Timeout-Antworten zu vermeiden.

Anleitung:

Fügen Sie es in den Plugin-Code ein, an dem Sie das Plugin stoppen möchten, und es zeigt eine Fehlermeldung an.


<?php wp_die( __("Your PHP version isn't up-to-date, please <a href="http://php.net">update</a>.") ); ?>

Für heute grüße ich dich.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.